What’s Vulnerable › Vulnerabilities
CVE-2022-40208
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-24 · updated 2026-06-17
- Weakness: CWE-285
Description
In Moodle, insufficient limitations in some quiz web services made it possible for students to bypass sequential navigation during a quiz attempt.
Affected products
- Moodle: from 3.9.0 (excl.) before 3.9.16; from 3.11.0 (excl.) before 3.11.9; from 4.0.0 (excl.) before 4.0.3; 3.9.0, 3.11.0, 4.0.0 — fixed in 3.11.9, 3.9.16, 4.0.3
How to fix
Upgrade to a fixed version: Moodle 3.11.9, 3.9.16, 4.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-40208 or the next vulnerability affects your stack