What’s Vulnerable › Vulnerabilities
CVE-2022-4021: Permalink Manager Lite <= 2.2.20.1 - Cross-Site Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-16 · updated 2026-06-17
- Weakness: CWE-352
Description
The Permalink Manager Lite plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.2.20.1. This is due to missing or incorrect nonce validation on the extra_actions function. This makes it possible for unauthenticated attackers to change plugin settings including permalinks and site maps, via forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- mbis Permalink Manager Lite: before 2.2.20.2 — fixed in 2.2.20.2
How to fix
Upgrade to a fixed version: mbis Permalink Manager Lite 2.2.20.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2818142#file34
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1718f2eb-6235-498f-8c1e-402c1caf7d02?source=cve
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-4021
- https://plugins.trac.wordpress.org/changeset/2818142#file34
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-4021
Get alerted when CVE-2022-4021 or the next vulnerability affects your stack