What’s Vulnerable › Vulnerabilities
CVE-2022-40211: WordPress GiveWP plugin <= 2.25.1 - Cross Site Scripting (XSS) via render_dropdown vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GiveWP allows Stored XSS.This issue affects GiveWP: from n/a through 2.25.1.
Affected products
- stellarwp GiveWP – Donation Plugin and Fundraising Platform: before 2.25.2 — fixed in 2.25.2
How to fix
Upgrade to a fixed version: stellarwp GiveWP – Donation Plugin and Fundraising Platform 2.25.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/give/wordpress-givewp-plugin-2-25-1-cross-site-scripting-xss-via-render-dropdown-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/give/wordpress-givewp-plugin-2-25-1-cross-site-scripting-xss-via-render-dropdown-vulnerability?_s_id=cve
Get alerted when CVE-2022-40211 or the next vulnerability affects your stack