What’s Vulnerable › Vulnerabilities
CVE-2022-4023: 3DPrint < 3.5.6.9 - CSRF to arbitrary file downlad
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-17 · updated 2026-06-17
Description
The 3DPrint WordPress plugin before 3.5.6.9 does not protect against CSRF attacks in the modified version of Tiny File Manager included with the plugin, allowing an attacker to craft a malicious request that will create an archive of any files or directories on the target server by tricking a logged in admin into submitting a form. Furthermore the created archive has a predictable location and name, allowing the attacker to download the file if they know the time at which the form was submitted, making it possible to leak sensitive files like the WordPress configuration containing database credentials and secrets.
Affected products
- 3dprint: before 3.5.6.9 — fixed in 3.5.6.9
How to fix
Upgrade to a fixed version: 3dprint 3.5.6.9. Check the vendor advisory for mitigations.
References
- https://jetpack.com/blog/vulnerabilities-found-in-the-3dprint-premium-plugin/
- https://wpscan.com/vulnerability/859c6e7e-2381-4d93-a526-2000b4fb8fee
- https://jetpack.com/blog/vulnerabilities-found-in-the-3dprint-premium-plugin/
- https://wpscan.com/vulnerability/859c6e7e-2381-4d93-a526-2000b4fb8fee
Get alerted when CVE-2022-4023 or the next vulnerability affects your stack