What’s Vulnerable › Vulnerabilities
CVE-2022-40313
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
Affected products
- Fedoraproject Extra Packages For Enterprise Linux: 8.0
- Fedoraproject Fedora: 35, 36
- Moodle: from 3.9.0 before 3.9.17; from 3.11.0 before 3.11.10; from 4.0.0 before 4.0.4 — fixed in 3.11.10, 3.9.17, 4.0.4
How to fix
Upgrade to a fixed version: Moodle 3.11.10, 3.9.17, 4.0.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2128146
- https://moodle.org/mod/forum/discuss.php?d=438392
- https://bugzilla.redhat.com/show_bug.cgi?id=2128146
- https://moodle.org/mod/forum/discuss.php?d=438392
Get alerted when CVE-2022-40313 or the next vulnerability affects your stack