What’s Vulnerable › Vulnerabilities
CVE-2022-40314
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-30 · updated 2026-06-17
- Weakness: CWE-502
Description
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
Affected products
- Moodle: from 3.9 before 3.9.17; from 3.11 before 3.11.10; from 4.0 before 4.0.4 — fixed in 3.11.10, 3.9.17, 4.0.4
How to fix
Upgrade to a fixed version: Moodle 3.11.10, 3.9.17, 4.0.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2128147
- https://moodle.org/mod/forum/discuss.php?d=438393
- https://bugzilla.redhat.com/show_bug.cgi?id=2128147
- https://moodle.org/mod/forum/discuss.php?d=438393
Get alerted when CVE-2022-40314 or the next vulnerability affects your stack