What’s Vulnerable › Vulnerabilities
CVE-2022-4048: CODESYS V3 prone to Inadequate Encryption Stregth
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-15 · updated 2026-06-17
- Weakness: CWE-326
Description
Inadequate Encryption Strength in CODESYS Development System V3 versions prior to V3.5.18.40 allows an unauthenticated local attacker to access and manipulate code of the encrypted boot application.
Affected products
- CODESYS Development System V3: before 3.5.18.40 — fixed in 3.5.18.40
How to fix
Upgrade to a fixed version: CODESYS Development System V3 3.5.18.40. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17350&token=2cee62285d3ec76d6a78dfa9b9e81e66f6136a2a&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17350&token=2cee62285d3ec76d6a78dfa9b9e81e66f6136a2a&download=
Get alerted when CVE-2022-4048 or the next vulnerability affects your stack