What’s Vulnerable › Vulnerabilities
CVE-2022-4057: Autoptimize < 3.1.0 - Sensitive Data Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
- Weakness: CWE-425
Description
The Autoptimize WordPress plugin before 3.1.0 uses an easily guessable path to store plugin's exported settings and logs.
Affected products
- optimizingmatters Autooptimize: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: optimizingmatters Autooptimize 3.1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/95ee1b9c-1971-4c35-8527-5764e9ed64af
- https://wpscan.com/vulnerability/95ee1b9c-1971-4c35-8527-5764e9ed64af
Get alerted when CVE-2022-4057 or the next vulnerability affects your stack