What’s Vulnerable › Vulnerabilities
CVE-2022-40617
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-400
Description
strongSwan before 5.9.8 allows remote attackers to cause a denial of service in the revocation plugin by sending a crafted end-entity (and intermediate CA) certificate that contains a CRL/OCSP URL that points to a server (under the attacker's control) that doesn't properly respond but (for example) just does nothing after the initial TCP handshake, or sends an excessive amount of application data.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04, 22.04
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 37
- Stormshield Network Security: from 3.11.1 before 3.11.20; from 4.3.1 before 4.3.15; from 4.5.1 before 4.6.0 — fixed in 3.11.20, 4.3.15, 4.6.0
- strongSwan: before 5.9.8 — fixed in 5.9.8
How to fix
Upgrade to a fixed version: Stormshield Network Security 3.11.20, 4.3.15, 4.6.0; strongSwan 5.9.8. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J3GAYIOCSLU57C45CO4UE4IV4JZE4W3L/
- https://www.strongswan.org/blog/2022/10/03/strongswan-vulnerability-%28cve-2022-40617%29.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J3GAYIOCSLU57C45CO4UE4IV4JZE4W3L/
- https://www.strongswan.org/blog/2022/10/03/strongswan-vulnerability-%28cve-2022-40617%29.html
Get alerted when CVE-2022-40617 or the next vulnerability affects your stack