What’s Vulnerable › Vulnerabilities
CVE-2022-40619
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-77
Description
FunJSQ, a third-party module integrated on some NETGEAR routers and Orbi WiFi Systems, exposes an HTTP server over the LAN interface of affected devices. This interface is vulnerable to unauthenticated arbitrary command injection through the funjsq_access_token parameter. This affects R6230 before 1.1.0.112, R6260 before 1.1.0.88, R7000 before 1.0.11.134, R8900 before 1.0.5.42, R9000 before 1.0.5.42, and XR300 before 1.0.3.72 and Orbi RBR20 before 2.7.2.26, RBR50 before 2.7.4.26, RBS20 before 2.7.2.26, and RBS50 before 2.7.4.26.
Affected products
- NETGEAR R6230 Firmware: before 1.1.0.112 — fixed in 1.1.0.112
- NETGEAR R6260: before 1.1.0.88 — fixed in 1.1.0.88
- NETGEAR R7000: before 1.0.11.134 — fixed in 1.0.11.134
- NETGEAR R8900 Firmware: before 1.0.5.42 — fixed in 1.0.5.42
- NETGEAR R9000 Firmware: before 1.0.5.42 — fixed in 1.0.5.42
- NETGEAR Rax120 Firmware: before 1.2.8.40 — fixed in 1.2.8.40
- NETGEAR Rax120V2 Firmware: before 1.2.8.40 — fixed in 1.2.8.40
- NETGEAR Rbr20 Firmware: before 2.7.2.26 — fixed in 2.7.2.26
- NETGEAR Rbs20 Firmware: before 2.7.2.26 — fixed in 2.7.2.26
- NETGEAR Xr300 Firmware: before 1.0.3.72 — fixed in 1.0.3.72
How to fix
Upgrade to a fixed version: NETGEAR R6230 Firmware 1.1.0.112; NETGEAR R6260 1.1.0.88; NETGEAR R7000 1.0.11.134; NETGEAR R8900 Firmware 1.0.5.42; NETGEAR R9000 Firmware 1.0.5.42; NETGEAR Rax120 Firmware 1.2.8.40; NETGEAR Rax120V2 Firmware 1.2.8.40; NETGEAR Rbr20 Firmware 2.7.2.26; NETGEAR Rbs20 Firmware 2.7.2.26; NETGEAR Xr300 Firmware 1.0.3.72. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065132/Security-Advisory-for-Vulnerabilities-in-FunJSQ-on-Some-Routers-and-Orbi-WiFi-Systems-PSV-2022-0117
- https://www.onekey.com/resource/security-advisory-netgear-routers-funjsq-vulnerabilities
Get alerted when CVE-2022-40619 or the next vulnerability affects your stack