What’s Vulnerable › Vulnerabilities

CVE-2022-40620

Description

FunJSQ, a third-party module integrated on some NETGEAR routers and Orbi WiFi Systems, does not properly validate TLS certificates when downloading update packages through its auto-update mechanism. An attacker (suitably positioned on the network) could intercept the update request and deliver a malicious update package in order to gain arbitrary code execution on affected devices. This affects R6230 before 1.1.0.112, R6260 before 1.1.0.88, R7000 before 1.0.11.134, R8900 before 1.0.5.42, R9000 before 1.0.5.42, and XR300 before 1.0.3.72 and Orbi RBR20 before 2.7.2.26, RBR50 before 2.7.4.26, RBS20 before 2.7.2.26, and RBS50 before 2.7.4.26.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR R6230 Firmware 1.1.0.112; NETGEAR R6260 1.1.0.88; NETGEAR R7000 1.0.11.134; NETGEAR R8900 Firmware 1.0.5.42; NETGEAR R9000 Firmware 1.0.5.42; NETGEAR Rax120 Firmware 1.2.8.40; NETGEAR Rax120V2 Firmware 1.2.8.40; NETGEAR Rbr20 Firmware 2.7.2.26; NETGEAR Rbs20 Firmware 2.7.2.26; NETGEAR Xr300 Firmware 1.0.3.72. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-40620 or the next vulnerability affects your stack