What’s Vulnerable › Vulnerabilities
CVE-2022-40624
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-20 · updated 2026-06-17
- Weakness: CWE-78
Description
pfSense pfBlockerNG through 2.1.4_27 allows remote attackers to execute arbitrary OS commands as root via the HTTP Host header, a different vulnerability than CVE-2022-31814.
Affected products
- pfSense Pfblockerng: before 2.1.4_27 — fixed in 2.1.4_27
How to fix
Upgrade to a fixed version: pfSense Pfblockerng 2.1.4_27. Check the vendor advisory for mitigations.
References
- https://docs.netgate.com/pfsense/en/latest/packages/pfblocker.html
- https://github.com/dhammon/pfBlockerNg-CVE-2022-40624
- https://github.com/dhammon/pfBlockerNg-RCE
- https://docs.netgate.com/pfsense/en/latest/packages/pfblocker.html
- https://github.com/dhammon/pfBlockerNg-CVE-2022-40624
- https://github.com/dhammon/pfBlockerNg-RCE
Get alerted when CVE-2022-40624 or the next vulnerability affects your stack