What’s Vulnerable › Vulnerabilities
CVE-2022-4064: Dalli Meta Protocol request_formatter.rb self.meta_set injection
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-19 · updated 2026-06-17
- Weakness: CWE-74
Description
A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.
Affected products
- Dalli: from - before 3.2.3 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: Dalli 3.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-3xg8-cc8f-9wv2
- https://github.com/petergoldstein/dalli/commit/48d594dae55934476fec61789e7a7c3700e0f50d
- https://github.com/petergoldstein/dalli/issues/932
- https://github.com/petergoldstein/dalli/pull/933
- https://github.com/petergoldstein/dalli/releases/tag/v3.2.3
- https://vuldb.com/?ctiid.214026
- https://vuldb.com/?id.214026
- https://github.com/petergoldstein/dalli/commit/48d594dae55934476fec61789e7a7c3700e0f50d
- https://github.com/petergoldstein/dalli/issues/932
- https://github.com/petergoldstein/dalli/pull/933
- https://vuldb.com/?id.214026
Get alerted when CVE-2022-4064 or the next vulnerability affects your stack