What’s Vulnerable › Vulnerabilities
CVE-2022-40675
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-310
Description
Some cryptographic issues in Fortinet FortiNAC versions 9.4.0 through 9.4.1, 9.2.0 through 9.2.7, 9.1.0 through 9.1.8, 8.8.0 through 8.8.11, 8.7.0 through 8.7.6, 8.6.0 through 8.6.5, 8.5.0 through 8.5.4, 8.3.7 may allow an attacker to decrypt and forge protocol communication messages.
Affected products
- Fortinet FortiNAC: from 8.3.7 through 9.2.7; from 9.4.0 before 9.4.2 — fixed in 9.4.2
- Fortinet FortiNAC-F: before 7.2.0 — fixed in 7.2.0
How to fix
Upgrade to a fixed version: Fortinet FortiNAC 9.4.2; Fortinet FortiNAC-F 7.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-40675 or the next vulnerability affects your stack