What’s Vulnerable › Vulnerabilities

CVE-2022-40679

Description

An improper neutralization of special elements used in an OS command vulnerability [CWE-78] in FortiADC 5.x all versions, 6.0 all versions, 6.1 all versions, 6.2.0 through 6.2.4, 7.0.0 through 7.0.3, 7.1.0; FortiDDoS 4.x all versions, 5.0 all versions, 5.1 all versions, 5.2 all versions, 5.3 all versions, 5.4 all versions, 5.5 all versions, 5.6 all versions and FortiDDoS-F 6.4.0, 6.3.0 through 6.3.3, 6.2.0 through 6.2.2, 6.1.0 through 6.1.4 may allow an authenticated attacker to execute unauthorized commands via specifically crafted arguments to existing commands.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiADC 6.2.5; Fortinet FortiDDoS 5.7.0; Fortinet FortiDDoS-F 6.1.5, 6.2.3, 6.3.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-40679 or the next vulnerability affects your stack