What’s Vulnerable › Vulnerabilities
CVE-2022-4068: Improperly Controlled Modification of Dynamically-Determined Object Attributes in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 37.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-20 · updated 2026-06-17
- Weakness: CWE-915
Description
A user is able to enable their own account if it was disabled by an admin while the user still holds a valid session. Moreover, the username is not properly sanitized in the admin user overview. This enables an XSS attack that enables an attacker with a low privilege user to execute arbitrary JavaScript in the context of an admin's account.
Affected products
- librenms: before 22.10.0 — fixed in 22.10.0
How to fix
Upgrade to a fixed version: librenms 22.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/09a2977adb8bc4b1db116c725d661160c930d3a1
- https://huntr.dev/bounties/becfecc4-22a6-4f94-bf83-d6030b625fdc
- https://github.com/librenms/librenms/commit/09a2977adb8bc4b1db116c725d661160c930d3a1
- https://huntr.dev/bounties/becfecc4-22a6-4f94-bf83-d6030b625fdc
Get alerted when CVE-2022-4068 or the next vulnerability affects your stack