What’s Vulnerable › Vulnerabilities
CVE-2022-40682
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-11 · updated 2026-06-17
- Weakness: CWE-863
Description
A incorrect authorization in Fortinet FortiClient (Windows) 7.0.0 - 7.0.7, 6.4.0 - 6.4.9, 6.2.0 - 6.2.9 and 6.0.0 - 6.0.10 allows an attacker to execute unauthorized code or commands via sending a crafted request to a specific named pipe.
Affected products
- Fortinet FortiClientWindows: from 6.0.0 through 6.0.10; from 6.2.0 through 6.2.9; from 6.4.0 through 6.4.9; from 7.0.0 before 7.0.8 — fixed in 7.0.8
How to fix
Upgrade to a fixed version: Fortinet FortiClientWindows 7.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-40682 or the next vulnerability affects your stack