What’s Vulnerable › Vulnerabilities
CVE-2022-4069: Cross-site Scripting (XSS) - Generic in librenms/librenms
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 93.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Generic in GitHub repository librenms/librenms prior to 22.10.0.
Affected products
- librenms: before 22.10.0 — fixed in 22.10.0
How to fix
Upgrade to a fixed version: librenms 22.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/8383376f1355812e09ec0c2af67f6d46891b7ba7
- https://huntr.dev/bounties/a9925d98-dac4-4c3c-835a-d93aeecfb2c5
- https://github.com/librenms/librenms/commit/8383376f1355812e09ec0c2af67f6d46891b7ba7
- https://huntr.dev/bounties/a9925d98-dac4-4c3c-835a-d93aeecfb2c5
Get alerted when CVE-2022-4069 or the next vulnerability affects your stack