What’s Vulnerable › Vulnerabilities
CVE-2022-40690
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting vulnerability in BookStack versions prior to v22.09 allows a remote authenticated attacker to inject an arbitrary script.
Affected products
- bookstackapp/bookstack: before 22.09 — fixed in 22.09
How to fix
Upgrade to a fixed version: bookstackapp/bookstack 22.09. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN78862034/index.html
- https://www.bookstackapp.com/blog/bookstack-release-v22-09/
- https://www.bookstackapp.com/docs/admin/security/#using-bookstack-content-externally
- https://jvn.jp/en/jp/JVN78862034/index.html
- https://www.bookstackapp.com/blog/bookstack-release-v22-09/
- https://www.bookstackapp.com/docs/admin/security/#using-bookstack-content-externally
Get alerted when CVE-2022-40690 or the next vulnerability affects your stack