What’s Vulnerable › Vulnerabilities
CVE-2022-4070: Insufficient Session Expiration in librenms/librenms
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-20 · updated 2026-06-17
- Weakness: CWE-613
Description
Insufficient Session Expiration in GitHub repository librenms/librenms prior to 22.10.0.
Affected products
- librenms: before 22.10.0 — fixed in 22.10.0
How to fix
Upgrade to a fixed version: librenms 22.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/ce8e5f3d056829bfa7a845f9dc2757e21e419ddc
- https://huntr.dev/bounties/72d426bb-b56e-4534-88ba-0d11381b0775
- https://github.com/librenms/librenms/commit/ce8e5f3d056829bfa7a845f9dc2757e21e419ddc
- https://huntr.dev/bounties/72d426bb-b56e-4534-88ba-0d11381b0775
Get alerted when CVE-2022-4070 or the next vulnerability affects your stack