What’s Vulnerable › Vulnerabilities
CVE-2022-40744: IBM Aspera Faspex cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-02 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Aspera Faspex 5.0.6 is vulnerable to stored cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 236441.
Affected products
- IBM Aspera Faspex: before 5.0.7 — fixed in 5.0.7
How to fix
Upgrade to a fixed version: IBM Aspera Faspex 5.0.7. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/236441
- https://www.ibm.com/support/pages/node/7111778
- https://exchange.xforce.ibmcloud.com/vulnerabilities/236441
- https://www.ibm.com/support/pages/node/7111778
Get alerted when CVE-2022-40744 or the next vulnerability affects your stack