What’s Vulnerable › Vulnerabilities
CVE-2022-40778
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored Cross-Site Scripting (XSS) vulnerability in OPSWAT MetaDefender ICAP Server before 4.13.0 allows attackers to execute arbitrary JavaScript or HTML because of the blocked page response.
Affected products
- OPSWAT Metadefender: before 4.13.0 — fixed in 4.13.0
How to fix
Upgrade to a fixed version: OPSWAT Metadefender 4.13.0. Check the vendor advisory for mitigations.
References
- https://docs.opswat.com/mdicap/release-notes
- https://www.opswat.com/products/metadefender/icap
- https://docs.opswat.com/mdicap/release-notes
- https://www.opswat.com/products/metadefender/icap
Get alerted when CVE-2022-40778 or the next vulnerability affects your stack