What’s Vulnerable › Vulnerabilities
CVE-2022-40798
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-19 · updated 2026-06-17
- Weakness: CWE-284
Description
OcoMon 4.0RC1 is vulnerable to Incorrect Access Control. Through a request the user can obtain the real email, sending the same request with correct email its possible to account takeover.
Affected products
- Ocomon Project Ocomon: before 4.0; 4.0, 4.0-rc1 — fixed in 4.0
How to fix
Upgrade to a fixed version: Ocomon Project Ocomon 4.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/ninj4c0d3r/89bdd6702bf00d768302f5e0e5bb8adc
- https://ocomonphp.sourceforge.io/
- https://gist.github.com/ninj4c0d3r/89bdd6702bf00d768302f5e0e5bb8adc
- https://ocomonphp.sourceforge.io/
Get alerted when CVE-2022-40798 or the next vulnerability affects your stack