What’s Vulnerable › Vulnerabilities
CVE-2022-40816
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-27 · updated 2026-06-17
- Weakness: CWE-863
Description
Zammad 5.2.1 is vulnerable to Incorrect Access Control. Zammad's asset handling mechanism has logic to ensure that customer users are not able to see personal information of other users. This logic was not effective when used through a web socket connection, so that a logged-in attacker would be able to fetch personal data of other users by querying the Zammad API. This issue is fixed in , 5.2.2.
Affected products
- zammad: from 5.2.0 before 5.2.2 — fixed in 5.2.2
How to fix
Upgrade to a fixed version: zammad 5.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-40816 or the next vulnerability affects your stack