What’s Vulnerable › Vulnerabilities
CVE-2022-40897: pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS)
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-23 · updated 2026-06-17
- Weakness: CWE-1333
Description
Python Packaging Authority (PyPA) setuptools before 65.5.1 allows remote attackers to cause a denial of service via HTML in a crafted package or custom PackageIndex page. There is a Regular Expression Denial of Service (ReDoS) in package_index.py.
Affected products
- pypa setuptools: before 65.5.1 — fixed in 65.5.1
- Pypi Setuptools: before 65.5.1; 0.6b1, 0.6b2, 0.6b3, 0.6b4, 0.6c1, 0.6c10 (+494) — fixed in 65.5.1
How to fix
Upgrade to a fixed version: pypa setuptools 65.5.1; Pypi Setuptools 65.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/pypa/setuptools/blob/fe8a98e696241487ba6ac9f91faa38ade939ec5d/setuptools/package_index.py#L200
- https://github.com/pypa/setuptools/commit/43a9c9bfa6aa626ec2a22540bea28d2ca77964be
- https://github.com/pypa/setuptools/compare/v65.5.0...v65.5.1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ADES3NLOE5QJKBLGNZNI2RGVOSQXA37R/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YNA2BAH2ACBZ4TVJZKFLCR7L23BG5C3H/
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/
- https://pyup.io/vulnerabilities/CVE-2022-40897/52495/
- https://security.netapp.com/advisory/ntap-20230214-0001/
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://github.com/pypa/setuptools/blob/fe8a98e696241487ba6ac9f91faa38ade939ec5d/setuptools/package_index.py#L200
- https://github.com/pypa/setuptools/commit/43a9c9bfa6aa626ec2a22540bea28d2ca77964be
- https://github.com/pypa/setuptools/compare/v65.5.0...v65.5.1
Get alerted when CVE-2022-40897 or the next vulnerability affects your stack