What’s Vulnerable › Vulnerabilities
CVE-2022-40898: pypa/wheel vulnerable to Regular Expression denial of service (ReDoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-23 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue discovered in Python Packaging Authority (PyPA) Wheel 0.37.1 and earlier allows remote attackers to cause a denial of service via attacker controlled input to wheel cli.
Affected products
- pypa wheel: before 0.38.1 — fixed in 0.38.1
- Pypi Wheel: before 0.38.1; 0.1, 0.10.0, 0.10.1, 0.10.2, 0.10.3, 0.11.0 (+58) — fixed in 0.38.1
How to fix
Upgrade to a fixed version: pypa wheel 0.38.1; Pypi Wheel 0.38.1. Check the vendor advisory for mitigations.
References
- https://github.com/pypa/wheel/blob/main/src/wheel/wheelfile.py#L18
- https://pypi.org/project/wheel/
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/
- https://github.com/pypa/wheel/blob/main/src/wheel/wheelfile.py#L18
- https://pypi.org/project/wheel/
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/
Get alerted when CVE-2022-40898 or the next vulnerability affects your stack