What’s Vulnerable › Vulnerabilities
CVE-2022-40955: Deserialization attack in Apache InLong prior to version 1.3.0 allows RCE via JDBC
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-20 · updated 2026-06-17
- Weakness: CWE-502
Description
In versions of Apache InLong prior to 1.3.0, an attacker with sufficient privileges to specify MySQL JDBC connection URL parameters and to write arbitrary data to the MySQL database, could cause this data to be deserialized by Apache InLong, potentially leading to Remote Code Execution on the Apache InLong server. Users are advised to upgrade to Apache InLong 1.3.0 or newer.
Affected products
- Apache Software Foundation Apache InLong: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache InLong 1.3.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/09/22/5
- https://lists.apache.org/thread/r1r34y7bchrpmp9jhfdoohzdmk7pj1q1
- http://www.openwall.com/lists/oss-security/2022/09/22/5
- https://lists.apache.org/thread/r1r34y7bchrpmp9jhfdoohzdmk7pj1q1
Get alerted when CVE-2022-40955 or the next vulnerability affects your stack