What’s Vulnerable › Vulnerabilities
CVE-2022-40960
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-416
Description
Concurrent use of the URL parser with non-UTF-8 data was not thread-safe. This could lead to a use-after-free causing a potentially exploitable crash. This vulnerability affects Firefox ESR < 102.3, Thunderbird < 102.3, and Firefox < 105.
Affected products
- Mozilla Firefox: before 105.0 — fixed in 105.0
- Mozilla Firefox ESR: before 102.3 — fixed in 102.3
- Mozilla Thunderbird: before 102.3 — fixed in 102.3
How to fix
Upgrade to a fixed version: Mozilla Firefox 105.0; Mozilla Firefox ESR 102.3; Mozilla Thunderbird 102.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1787633
- https://www.mozilla.org/security/advisories/mfsa2022-40/
- https://www.mozilla.org/security/advisories/mfsa2022-41/
- https://www.mozilla.org/security/advisories/mfsa2022-42/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1787633
- https://www.mozilla.org/security/advisories/mfsa2022-40/
- https://www.mozilla.org/security/advisories/mfsa2022-41/
- https://www.mozilla.org/security/advisories/mfsa2022-42/
Get alerted when CVE-2022-40960 or the next vulnerability affects your stack