What’s Vulnerable › Vulnerabilities
CVE-2022-40978
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-427
Description
The installer of JetBrains IntelliJ IDEA before 2022.2.2 was vulnerable to EXE search order hijacking
Affected products
- JetBrains IntelliJ IDEA: before 2022.2.2 — fixed in 2022.2.2
How to fix
Upgrade to a fixed version: JetBrains IntelliJ IDEA 2022.2.2. Check the vendor advisory for mitigations.
References
- https://www.jetbrains.com/privacy-security/issues-fixed/
- https://www.jetbrains.com/privacy-security/issues-fixed/
Get alerted when CVE-2022-40978 or the next vulnerability affects your stack