What’s Vulnerable › Vulnerabilities
CVE-2022-40984
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-24 · updated 2026-06-17
- Weakness: CWE-787
Description
Stack-based buffer overflow in WTViewerE series WTViewerE 761941 from 1.31 to 1.61 and WTViewerEfree from 1.01 to 1.52 allows an attacker to cause the product to crash by processing a long file name.
Affected products
- Yokogawa Wtviewere 761941: from 1.31 before 1.62 — fixed in 1.62
- Yokogawa Wtviewerefree: from 1.01 before 1.53 — fixed in 1.53
How to fix
Upgrade to a fixed version: Yokogawa Wtviewere 761941 1.62; Yokogawa Wtviewerefree 1.53. Check the vendor advisory for mitigations.
References
- https://cdn.aff.yokogawa.com/8/756/details/Vulnerability_in_YOKOGAWA_application_software_WTViewerE_r0_e.pdf
- https://jvn.jp/en/vu/JVNVU99955870/index.html
- https://cdn.aff.yokogawa.com/8/756/details/Vulnerability_in_YOKOGAWA_application_software_WTViewerE_r0_e.pdf
- https://jvn.jp/en/vu/JVNVU99955870/index.html
Get alerted when CVE-2022-40984 or the next vulnerability affects your stack