What’s Vulnerable › Vulnerabilities
CVE-2022-4100: WP Cerber Security <= 9.4 - IP Protection Bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-31 · updated 2026-06-17
- Weakness: CWE-693
Description
The WP Cerber Security plugin for WordPress is vulnerable to IP Protection bypass in versions up to, and including 9.4 due to the plugin improperly checking for a visitor's IP address. This makes it possible for an attacker whose IP address has been blocked to bypass this control by setting the X-Forwarded-For: HTTP header to an IP Address that hasn't been blocked.
Affected products
- Wpcerber Cerber Security Antispam & Malware Scan: before 9.5 — fixed in 9.5
How to fix
Upgrade to a fixed version: Wpcerber Cerber Security Antispam & Malware Scan 9.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2865322/wp-cerber/trunk/cerber-common.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/03ccd474-42f4-4cbb-823e-93fe4db1bf80?source=cve
Get alerted when CVE-2022-4100 or the next vulnerability affects your stack