What’s Vulnerable › Vulnerabilities
CVE-2022-4102: Royal Elementor Addons < 1.3.56 - Subscriber+ Arbitrary Post Deletion
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-09 · updated 2026-06-17
- Weakness: CWE-352
Description
The Royal Elementor Addons WordPress plugin before 1.3.56 does not have authorization and CSRF checks when deleting a template and does not ensure that the post to be deleted is a template. This could allow any authenticated users, such as subscribers, to delete arbitrary posts assuming they know the related slug.
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.3.56 — fixed in 1.3.56
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.3.56. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c177f763-0bb5-4734-ba2e-7ba816578937
- https://wpscan.com/vulnerability/c177f763-0bb5-4734-ba2e-7ba816578937
Get alerted when CVE-2022-4102 or the next vulnerability affects your stack