What’s Vulnerable › Vulnerabilities
CVE-2022-4103: Royal Elementor Addons < 1.3.56 - Subscriber+ Arbitrary Post Creation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-09 · updated 2026-06-17
- Weakness: CWE-352
Description
The Royal Elementor Addons WordPress plugin before 1.3.56 does not have authorisation and CSRF checks when creating a template, and does not ensure that the post created is a template. This could allow any authenticated users, such as subscriber to create a post (as well as any post type) with an arbitrary title
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.3.56 — fixed in 1.3.56
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.3.56. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5e1244f7-39b5-4f37-8fef-e3f35fc388f1
- https://wpscan.com/vulnerability/5e1244f7-39b5-4f37-8fef-e3f35fc388f1
Get alerted when CVE-2022-4103 or the next vulnerability affects your stack