What’s Vulnerable › Vulnerabilities
CVE-2022-4105: Cross-site Scripting (XSS) - Stored in kiwitcms/kiwi
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-21 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored XSS in a kiwi Test Plan can run malicious javascript which could be chained with an HTML injection to perform a UI redressing attack (clickjacking) and an HTML injection which disables the use of the history page.
Affected products
- kiwitcms Kiwi: before 11.6 — fixed in 11.6
How to fix
Upgrade to a fixed version: kiwitcms Kiwi 11.6. Check the vendor advisory for mitigations.
References
- https://github.com/kiwitcms/kiwi/commit/a2b169ffdef1d7c1755bade8138578423b35011b
- https://huntr.dev/bounties/386417e9-0cd5-4d80-8137-b0fd5c30b8f8
- https://github.com/kiwitcms/kiwi/commit/a2b169ffdef1d7c1755bade8138578423b35011b
- https://huntr.dev/bounties/386417e9-0cd5-4d80-8137-b0fd5c30b8f8
Get alerted when CVE-2022-4105 or the next vulnerability affects your stack