What’s Vulnerable › Vulnerabilities
CVE-2022-4107: SMSA Shipping for WooCommerce < 1.0.5 - Subscriber+ Arbitrary File Download
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
Description
The SMSA Shipping for WooCommerce WordPress plugin before 1.0.5 does not have authorisation and proper CSRF checks, as well as does not validate the file to be downloaded, allowing any authenticated users, such as subscriber to download arbitrary file from the server
Affected products
- SMSA Shipping for WooCommerce: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: SMSA Shipping for WooCommerce 1.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0b432858-722c-4bda-aa95-ad48e2097302
- https://wpscan.com/vulnerability/0b432858-722c-4bda-aa95-ad48e2097302
Get alerted when CVE-2022-4107 or the next vulnerability affects your stack