What’s Vulnerable › Vulnerabilities
CVE-2022-41089: .NET Framework Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-13 · updated 2026-06-17
Description
.NET Framework Remote Code Execution Vulnerability
Affected products
- Microsoft .NET Framework: 3.5, 4.8, 4.6, 4.6.1, 4.6.2, 4.7 (+6)
- Microsoft .NET 6.0: from 6.0.0 before 6.0.12 — fixed in 6.0.12
- Microsoft .NET 7.0: from 7.0.0 before 7.0.1 — fixed in 7.0.1
- Microsoft .NET Core 3.1: from 3.1 before 3.1.32 — fixed in 3.1.32
- Microsoft .NET Framework 2.0 Service Pack 2: from 2.0.0 before 30729.8953 — fixed in 30729.8953
- Microsoft .NET Framework 3.0 Service Pack 2: from 3.0.0 before 30729.8953 — fixed in 30729.8953
- Microsoft .NET Framework 3.5: from 3.5.0 before 30729.8953 — fixed in 30729.8953
- Microsoft .NET Framework 3.5.1: from 3.5.0 before 30729.8953 — fixed in 30729.8953
- Microsoft .NET Framework 3.5 AND 4.6/4.6.2: from 10.0.0 before 10.0.10240.19624 — fixed in 10.0.10240.19624
- Microsoft .NET Framework 3.5 AND 4.7.2: from 4.7.0 before 04010.02 — fixed in 04010.02
- Microsoft .NET Framework 3.5 AND 4.8: from 4.8.0 before 04590.02 — fixed in 04590.02
- Microsoft .NET Framework 3.5 AND 4.8.1: from 4.8.1 before 09115.01 — fixed in 09115.01
- Microsoft .NET Framework 4.6.2: from 4.7.0 before 04010.02 — fixed in 04010.02
- Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2: from 4.7.0 before 04010.02 — fixed in 04010.02
- Microsoft .NET Framework 4.8: from 4.8.0 before 04590.02 — fixed in 04590.02
- Microsoft Visual Studio 2019 version 16.11 (includes 16.0 - 16.10): from 16.11.0 before 16.11.22 — fixed in 16.11.22
- Microsoft Visual Studio 2022 version 17.0: from 17.0.0 before 17.0.17 — fixed in 17.0.17
- Microsoft Visual Studio 2022 version 17.2: from 17.2.0 before 17.2.11 — fixed in 17.2.11
- Microsoft Visual Studio 2022 version 17.4: from 17.4.0 before 17.4.3 — fixed in 17.4.3
- Microsoft PowerShell 7.2: from 7.2.0 before 7.2.9 — fixed in 7.2.9
- Microsoft PowerShell 7.3: from 7.3.0 before 7.3.2 — fixed in 7.3.2
How to fix
Upgrade to a fixed version: Microsoft .NET 6.0 6.0.12; Microsoft .NET 7.0 7.0.1; Microsoft .NET Core 3.1 3.1.32; Microsoft .NET Framework 2.0 Service Pack 2 30729.8953; Microsoft .NET Framework 3.0 Service Pack 2 30729.8953; Microsoft .NET Framework 3.5 30729.8953; Microsoft .NET Framework 3.5.1 30729.8953; Microsoft .NET Framework 3.5 AND 4.6/4.6.2 10.0.10240.19624; Microsoft .NET Framework 3.5 AND 4.7.2 04010.02; Microsoft .NET Framework 3.5 AND 4.8 04590.02; Microsoft .NET Framework 3.5 AND 4.8.1 09115.01; Microsoft .NET Framework 4.6.2 04010.02. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-41089
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2022-41089
Get alerted when CVE-2022-41089 or the next vulnerability affects your stack