What’s Vulnerable › Vulnerabilities
CVE-2022-41131: Apache Airflow Hive Provider vulnerability (command injection via hive_cli connection)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Hive Provider, Apache Airflow allows an attacker to execute arbtrary commands in the task execution context, without write access to DAG files. This issue affects Hive Provider versions prior to 4.1.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case HIve Provider is installed (Hive Provider 4.1.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the HIve Provider version 4.1.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Hive Provider installed).
Affected products
- Apache Airflow: before 2.3.0 — fixed in 2.3.0
- Apache Software Foundation Apache Airflow Hive Provider: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.3.0; Apache Software Foundation Apache Airflow Hive Provider 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/27647
- https://lists.apache.org/thread/wwo3qp0z8gv54yzn7hr04wy4n8gb0vhl
- https://github.com/apache/airflow/pull/27647
- https://lists.apache.org/thread/wwo3qp0z8gv54yzn7hr04wy4n8gb0vhl
Get alerted when CVE-2022-41131 or the next vulnerability affects your stack