What’s Vulnerable › Vulnerabilities
CVE-2022-41138
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-20 · updated 2026-06-17
- Weakness: CWE-94
Description
In Zutty before 0.13, DECRQSS in text written to the terminal can achieve arbitrary code execution.
Affected products
- Zutty Project Zutty: before 0.13 — fixed in 0.13
How to fix
Upgrade to a fixed version: Zutty Project Zutty 0.13. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/868495
- https://github.com/tomszilagyi/zutty/commit/bde7458c60a7bafe08bbeaafbf861eb865edfa38
- https://github.com/tomszilagyi/zutty/compare/0.12...0.13
- https://security.gentoo.org/glsa/202209-25
- https://bugs.gentoo.org/868495
- https://github.com/tomszilagyi/zutty/commit/bde7458c60a7bafe08bbeaafbf861eb865edfa38
- https://github.com/tomszilagyi/zutty/compare/0.12...0.13
- https://security.gentoo.org/glsa/202209-25
Get alerted when CVE-2022-41138 or the next vulnerability affects your stack