What’s Vulnerable › Vulnerabilities
CVE-2022-4119: Image Optimizer, Resizer and CDN < 6.8.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
Description
The Image Optimizer, Resizer and CDN WordPress plugin before 6.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Image Optimizer, Resizer and CDN: before 6.8.1 — fixed in 6.8.1
How to fix
Upgrade to a fixed version: Image Optimizer, Resizer and CDN 6.8.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/11040133-c134-4f96-8421-edd04901ed0d
- https://wpscan.com/vulnerability/11040133-c134-4f96-8421-edd04901ed0d
Get alerted when CVE-2022-4119 or the next vulnerability affects your stack