What’s Vulnerable › Vulnerabilities
CVE-2022-4120: Stop Spammers Security < 2022.6 - Unauthenticated PHP Object Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-26 · updated 2026-06-17
Description
The Stop Spammers Security | Block Spam Users, Comments, Forms WordPress plugin before 2022.6 passes base64 encoded user input to the unserialize() PHP function when CAPTCHA are used as second challenge, which could lead to PHP Object injection if a plugin installed on the blog has a suitable gadget chain
Affected products
- Stop Spammers Security | Block Spam Users, Comments, Forms: before 2022.6 — fixed in 2022.6
How to fix
Upgrade to a fixed version: Stop Spammers Security | Block Spam Users, Comments, Forms 2022.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e8bb79db-ef77-43be-b449-4c4b5310eedf
- https://wpscan.com/vulnerability/e8bb79db-ef77-43be-b449-4c4b5310eedf
Get alerted when CVE-2022-4120 or the next vulnerability affects your stack