What’s Vulnerable › Vulnerabilities
CVE-2022-41224
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Jenkins 2.367 through 2.369 (both inclusive) does not escape tooltips of the l:helpIcon UI component used for some help icons on the Jenkins web UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control tooltips for this component.
Affected products
- Jenkins: from 2.367 before 2.370 — fixed in 2.370
How to fix
Upgrade to a fixed version: Jenkins 2.370. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2886
- https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2886
Get alerted when CVE-2022-41224 or the next vulnerability affects your stack