What’s Vulnerable › Vulnerabilities
CVE-2022-41227
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-21 · updated 2026-06-17
- Weakness: CWE-352
Description
A cross-site request forgery (CSRF) vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers to connect to an attacker-specified webserver using attacker-specified credentials.
Affected products
- Jenkins project Jenkins NS-ND Integration Performance Publisher Plugin: before 4.8.0.130 — fixed in 4.8.0.130
How to fix
Upgrade to a fixed version: Jenkins project Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.130. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2737
- https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2737
Get alerted when CVE-2022-41227 or the next vulnerability affects your stack