What’s Vulnerable › Vulnerabilities
CVE-2022-41297: IBM Db2U cross-site request forgery
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-01 · updated 2026-06-17
- Weakness: CWE-352
Description
IBM Db2U 3.5, 4.0, and 4.5 is vulnerable to cross-site request forgery which could allow an attacker to execute malicious and unauthorized actions transmitted from a user that the website trusts. IBM X-Force ID: 237212.
Affected products
- IBM Db2 on Cloud Pak for Data: from 3.5 before 4.6 — fixed in 4.6
- IBM Db2 Warehouse On Cloud Pak For Data: from 3.5 before 4.6 — fixed in 4.6
- IBM Db2U: 3.5, 4.0, 4.5
How to fix
Upgrade to a fixed version: IBM Db2 on Cloud Pak for Data 4.6; IBM Db2 Warehouse On Cloud Pak For Data 4.6. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/237212
- https://www.ibm.com/support/pages/node/6843071
- https://exchange.xforce.ibmcloud.com/vulnerabilities/237212
- https://www.ibm.com/support/pages/node/6843071
Get alerted when CVE-2022-41297 or the next vulnerability affects your stack