What’s Vulnerable › Vulnerabilities
CVE-2022-41299: IBM Cloud Transformation Advisor cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-09 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Cloud Transformation Advisor 2.0.1 through 3.3.1 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 237214.
Affected products
- IBM Cloud Transformation Advisor: from 2.0.1 before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: IBM Cloud Transformation Advisor 3.4.0. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/237214
- https://www.ibm.com/support/pages/node/6846257
- https://exchange.xforce.ibmcloud.com/vulnerabilities/237214
- https://www.ibm.com/support/pages/node/6846257
Get alerted when CVE-2022-41299 or the next vulnerability affects your stack