What’s Vulnerable › Vulnerabilities
CVE-2022-4131
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-12 · updated 2026-06-17
- Weakness: CWE-1333
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.8 before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. An attacker may cause Denial of Service on a GitLab instance by exploiting a regex issue in how the application parses user agents.
Affected products
- GitLab: from 10.8.0 before 15.5.7; from 15.6.0 before 15.6.4; from 15.7.0 before 15.7.2 — fixed in 15.5.7, 15.6.4, 15.7.2
How to fix
Upgrade to a fixed version: GitLab 15.5.7, 15.6.4, 15.7.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-4131.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/383598
- https://hackerone.com/reports/1772063
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-4131.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/383598
- https://hackerone.com/reports/1772063
Get alerted when CVE-2022-4131 or the next vulnerability affects your stack