What’s Vulnerable › Vulnerabilities
CVE-2022-41322
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-116
Description
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
Affected products
- Fedoraproject Fedora: 36, 37
- kitty project Kitty: before 0.26.2 — fixed in 0.26.2
How to fix
Upgrade to a fixed version: kitty project Kitty 0.26.2. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/868543
- https://github.com/kovidgoyal/kitty/commit/f05783e64d5fa62e1aed603e8d69aced5e49824f
- https://github.com/kovidgoyal/kitty/compare/v0.26.1...v0.26.2
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/47RK7MBSVY5BWDUTYMJUFPBAYFSWMTOI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6RRNAPU33PHEH64P77YL3AJO6CTZGHTX/
- https://security.gentoo.org/glsa/202209-22
- https://sw.kovidgoyal.net/kitty/changelog/#detailed-list-of-changes
- https://bugs.gentoo.org/868543
- https://github.com/kovidgoyal/kitty/commit/f05783e64d5fa62e1aed603e8d69aced5e49824f
- https://github.com/kovidgoyal/kitty/compare/v0.26.1...v0.26.2
- https://lists.debian.org/debian-lts-announce/2025/06/msg00000.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/47RK7MBSVY5BWDUTYMJUFPBAYFSWMTOI/
Get alerted when CVE-2022-41322 or the next vulnerability affects your stack