What’s Vulnerable › Vulnerabilities

CVE-2022-41323: Django denial-of-service vulnerability in internationalized URLs

Description

In Django 3.2 before 3.2.16, 4.0 before 4.0.8, and 4.1 before 4.1.2, internationalized URLs were subject to a potential denial of service attack via the locale parameter, which is treated as a regular expression.

Affected products

How to fix

Upgrade to a fixed version: Django 3.2.16, 4.0.8, 4.1.2; Pypi Django 3.2.16, 4.0.8, 4.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-41323 or the next vulnerability affects your stack