What’s Vulnerable › Vulnerabilities
CVE-2022-41340
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-24 · updated 2026-06-17
- Weakness: CWE-347
Description
The secp256k1-js package before 1.1.0 for Node.js implements ECDSA without required r and s validation, leading to signature forgery.
Affected products
- Secp256K1-Js Project Secp256K1-Js: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: Secp256K1-Js Project Secp256K1-Js 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/lionello/secp256k1-js/commit/302800f0370b42e360a33774bb808274ac729c2e
- https://github.com/lionello/secp256k1-js/compare/1.0.1...1.1.0
- https://github.com/lionello/secp256k1-js/issues/11
- https://www.npmjs.com/package/%40lionello/secp256k1-js
- https://github.com/lionello/secp256k1-js/commit/302800f0370b42e360a33774bb808274ac729c2e
- https://github.com/lionello/secp256k1-js/compare/1.0.1...1.1.0
- https://github.com/lionello/secp256k1-js/issues/11
- https://www.npmjs.com/package/%40lionello/secp256k1-js
Get alerted when CVE-2022-41340 or the next vulnerability affects your stack