What’s Vulnerable › Vulnerabilities
CVE-2022-41342
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-06 · updated 2026-06-17
- Weakness: CWE-119
Description
Improper buffer restrictions in the Intel(R) C++ Compiler Classic before version 2021.7.1 for some Intel(R) oneAPI Toolkits before version 2022.3.1 may allow a privileged user to potentially enable escalation of privilege via local access.
Affected products
- Intel(R) C++ Compiler Classic before version 2021.7.1 for some Intel(R) oneAPI Toolkits: before 2021.7.1 — fixed in 2021.7.1
How to fix
Upgrade to a fixed version: Intel(R) C++ Compiler Classic before version 2021.7.1 for some Intel(R) oneAPI Toolkits 2021.7.1. Check the vendor advisory for mitigations.
References
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00773.html
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00773.html
Get alerted when CVE-2022-41342 or the next vulnerability affects your stack