What’s Vulnerable › Vulnerabilities
CVE-2022-4139
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-27 · updated 2026-10-14
- Weakness: CWE-281
Description
An incorrect TLB flush issue was found in the Linux kernel’s GPU i915 kernel driver, potentially leading to random memory corruption or data leaks. This flaw could allow a local user to crash the system or escalate their privileges on the system.
Affected products
- Linux kernel: from 5.4 before 5.4.226; from 5.5 before 5.10.157; from 5.11 before 5.15.81; from 5.16 before 6.0.11; 6.1, 6.1-rc1, 6.1-rc2, 6.1-rc3, 6.1-rc4, 6.1-rc5 (+1) — fixed in 5.10.157, 5.15.81, 5.4.226, 6.0.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.157, 5.15.81, 5.4.226, 6.0.11. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2147572
- https://security.netapp.com/advisory/ntap-20230309-0004/
- https://www.openwall.com/lists/oss-security/2022/11/30/1
- https://bugzilla.redhat.com/show_bug.cgi?id=2147572
- https://security.netapp.com/advisory/ntap-20230309-0004/
- https://www.openwall.com/lists/oss-security/2022/11/30/1
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2022-4139 or the next vulnerability affects your stack